Just a Hook(HDOJ 1698)

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.


Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind. 

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example. 

Sample Input

1
10
2
1 5 2
5 9 3

Sample Output

Case 1: The total value of the hook is 24.

My Code

带延迟标记的线段树的模板题了吧,延迟标记主要用于大量的区间更新时,更新的区间越大效率越高,单点更新的话,就没有什么用了

#include <iostream>
#include <cstring>
#include <cstdio>
#define maxn 100000 + 5
using namespace std;

struct node
{
    int v;      //区间和
    int l;      //区间边界
    int r;
    int len;    //区间长度
    int lazy;   //延迟标记
} tree[maxn << 2];//要开四倍大小

int t, n, q;
int cnt;

void pushup(int p)//子节点更新完,向上更新父节点
{
    tree[p].v = tree[p << 1].v + tree[p << 1 | 1].v;
}
void build(int l, int r, int p)
{
    tree[p].l = l;      //初始化
    tree[p].r = r;
    tree[p].len = r - l + 1;
    tree[p].lazy = 0;

    if (l == r)
    {
        tree[p].v = 1;  //初始为铜
        return;
    }

    int m = (l + r) >> 1;

    build(l, m, p << 1);
    build(m + 1, r, p << 1 | 1);

    pushup(p);          //切记向上更新
}
void pushdown(int p)//将延迟标记推下去
{
    if (tree[p].lazy)
    {
        tree[p << 1].v = tree[p].lazy * tree[p << 1].len;//更新子节点
        tree[p << 1 | 1].v = tree[p].lazy * tree[p << 1 | 1].len;

        tree[p << 1].lazy = tree[p << 1 | 1].lazy = tree[p].lazy; //延迟标记推下去
        tree[p].lazy = 0;           //记得去掉当前节点的延迟标记
    }
}
void update(int l, int r, int z, int p)
{
    if (l <= tree[p].l && tree[p].r <= r)   //若当前区间包含于查询区间
    {
        tree[p].v = z * tree[p].len;        //更新区间和和延迟标记
        tree[p].lazy = z;
        return;
    }

    pushdown(p);    //先将延迟标记推下去,更新子节点

    int m = (tree[p].l + tree[p].r) >> 1;

    if (l <= m)
        update(l, r, z, p << 1);
    if (r > m)
        update(l, r, z, p << 1 | 1);
    pushup(p);      //向上更新
}

int main()
{
    ios::sync_with_stdio(false);//数据较大,用scanf或者关同步
    cout.tie(NULL);
    cin >> t;
    while (t--)
    {
        cin >> n;
        build(1, n, 1);

        cin >> q;
        while (q--)
        {
            int x, y, z;
            cin >> x >> y >> z;
            update(x, y, z, 1);
        }
        //因为输出整段的和,所以不许要另外的函数了,直接输出即可
        cout << "Case " << ++cnt << ": The total value of the hook is " << tree[1].v << "." << endl;
    }
    return 0;
}